MongoDB Unavailiable
Updated
Oct 21 at 08:00pm HDT
We are investigating at this moment, but it seems that the MongoDB server is online on the panel?
Affected services
Updated
Oct 21 at 08:10am HDT
microservice's restarted and should be functional
Affected services
Updated
Oct 21 at 08:10am HDT
Issue: MongoDB in the Pterodactyl container crashed after long uptime. Logs indicated a fatal error in full-time diagnostic data capture (FTDC) when writing to /home/container/mongodb/diagnostic.data/metrics.interim.temp, causing the process to terminate while the container still reported "online".
Cause: FTDC attempted to write diagnostic data to a filesystem that doesn’t fully support it (common in containerized environments). Lack of root access prevented proper recovery, triggering the crash.
Resolution:
- Disabled FTDC in mongod.conf:
yaml
setParameter:
diagnosticDataCollectionEnabled: false`
Affected services
Created
Oct 21 at 08:07am HDT
MongoDB is unavailiable at the moment, blog's may fail to load
Affected services